One-time Payment Failures

Incident Report for BSA Online

Resolved

The issue causing one-time payments to fail for a subset of municipal units has been resolved. Payment processing is functioning normally.
Posted Jan 15, 2026 - 10:02 EST

Investigating

We’re investigating reports of some users not being able to make one time payments affecting some municipal units. Impacted components: Payments processing. We’ll share more as soon as we have it.
Next update by: 11:00am (EST)
Posted Jan 15, 2026 - 09:49 EST
This incident affected: Website.